Jump to content
Onda Forum
Gearbest Get Xiaomi Mi Band 3 for Free on Xiaomi Great Sale @GearBest promotion
Get Xiaomi Mi Band 3 for Free on Xiaomi Great Sale @GearBest

V989 Core8_v5.0_v4-test Firmware

Recommended Posts



I tried To installed Lollipop on my Tablet ONDA Air, but witn OndaSuite or PhoenixSuit, the progress bar stay 0%.

I have kikat 4.4.4 et 1.06 firware on my tablet.


Havce you an idea whereis the problem?


Thank you



Share this post

Link to post
Share on other sites

Hey, is it possible to update the v989 v5 to the latest lollipop update via windows 10?


I don't get it. Everytime there are problems with the driver or it says the firmware is wrong? I tried both with phoenixsuit and ondasuite.


I want to flash this firmware:

Share this post

Link to post
Share on other sites

Thank you for your reply. 

I'm the founder of a german Tech Blog AndroidKosmos.de and make an review of the onda. So Lollipop rom would be nice. 

The system info shows V989 Air Core8 -  A83 SoC and Firmware 2.0.1_V5.

Share this post

Link to post
Share on other sites

You have the AIR version, A83 SOC, this FIRMWARE  is for the A80 SOC.  The new official Onda Website shows your firmware to be the latest one for the 989 AIR version 5 Tablet. It was only uploaded on their site on the 23 of February.

Edited by Colin5619

Share this post

Link to post
Share on other sites

I was having a lot of shut down issues as well as not fully rebooting unless I had the tablet plugged in. So, I decided to reflash and the file is missing from here. Anyone know where I can find a copy?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Tuxu
      Hi all, thanks for trying to help.

      My onda v989 is already set to English but system notices - like the one I'm getting when I'm logging into my Wi-Fi network - are still in Chinese.
      Anyone knows how to change those into English?

      Please understand that I am referring to the actual system language and not to the user main language that I know how to change(Setting >> [A] Language&input >> Language (1st line) )

      I hope to learn Chinese in the next semester but I'd still rather have that text in English.
    • By nov kld
      I just purchased an onda v80 plus tablet version v5, windows 10 and android 5.0 operating system.
      I have met some problem.
      The screen keeps flashing and the tablet isnt responding every time I switch it on.
      The problem isnt occuring when i used an external mouse.
      I had already factory reset it for couples of time but the same problem still existing.
      any suggestion to solve it please?
    • By benda95280
      UPDATED 30/20/2016
      Hi everybody,
      I've just bought a Onda V989 Air V3.
      I'm happy with the new tablet for my last child, but i think the last version of the rom some have still some problems.
      (Or i'm the lucky owner of a defective tablet)
      I'll be happy to help other people, to find informations about the tablet, like roms, root ...
      So i'll try to do my best, with your help, to keep this post updated often.
      [General informations]
      Onda firmware ( published description) is designated device model and  hardware assembly version ( v# ) specific. 
      V989 Air v3 is designated as  " Black Gold Edition " device hardware version  ( 16 GB / 32 GB  ) Aug 2015 original firmware release 
      [RemixOs or Stock Rom]
      I'm on RemixOs since few Weeks, and i've no more crazy bugs like : Freeze during installation via Playstore, Laggs, Stockage issue ...
      When you boot, on the stock ROM i wasn"t having information like "Optimisation des Applications 1/102 ..." So you know when it is just Loading ...
      You have a cool TaskBar
          1. RemixOS
      - This Rom doesn't include gapps.
      - To have all languages, you have to find the tick box to unlock it. (Tell me where, i'll be happy to add the information here)
          [How to root]
      Use first link under, and unzip it into folder Root (created by you) on SdCard (Internal or ExtSD)
      Install "Update.apk" and launch it.
      Do [Local Update], search your previously created folder, and select "ondaos_v989_Root.zip", click [Update].
          [Links - Downloads]
          1. Only Root with SuperSu
      Link : http://www.mediafire.com/download/48cdh7ansltmvl4/Onda_V989_Root.rar
      My opinion: Work like a charm / Best Way to do it / Update SuperSu via Playstore work well with "normal installation"
          1. Flashfireapk [RECOMMENDED]
      Flash Without recovery
      My opinion: Work well for flashing Mods / ZIP on our V989
          2. LSpeed Mod [TESTED ON FRESH ROM] PlayStore
      My opinion: Launcher little less laggy..
          3. Universal Init.D [TESTED] Playstore
      My opinion: Working (TESTED with Creation of file test via folder Init.D)
          4. GovTuner
      Link : http://forum.xda-developers.com/android/software-hacking/mod-gov-tuner-project-29th-june-2016-t3407828
      Installation: FlashFire
      My opinion: Crazy !

          4. GL-Tools
      You want more fluidity in your games ? It's possible !
      Link : https://play.google.com/store/apps/details?id=com.n0n3m4.gltools
      How-to : http://www.theandroidhow.com/2014/06/play-high-end-games-with-gltools.html
          5. Titanium Backup
      Uninstall all chinese software with it.
      My opinion: Best way to remove chinese software !
          6. Nova launcher
      My opinion: Light and fluid
      [Bugs i've encountered on STOCK ROM]
      - During installing apps via Playstore (not downloading) it freeze all the tablet, and unfreeze when apps installed.
      - Some big games on playstore, donwload (Game + Additional data), install, and fail without reason or just blackscreen for some second and return to launcher.
      - With "Universal Init.D", Tweaks ABS, when i boot up the tablet, it's a little laggy and cannot have SU working for 1-2 mn, and see on bottom:
       "Init. Universal have got root permission accorded"
       "Lucky Patcher have got root permission accorded"
      After that, everything it's ok and smooth.
      (Maybe due to Universal Init.d that launch script ?)
      [What can be working on ?]
      - Cannot get working Link2SD
      I've try with / without second partition / EXT4, doesn't seen the partition.
      - Not enought space on "System partition" maybe add/extend 512Mb more ?
      - Have a debloated rom with init.d support
      - Found / Have a custom Recovery ? FlashFire
      - Try to get working OndaZ Air Rom: 
      I've tried it, but got some problems like: OP showed in front of applications size / Shutdown of the tabled under 59% / Games are "Slow" / Sometime lines bug with color are show
      (Take look at my post 30/10/2016)
      [ Read This ]
      Any Thanks, likes, or other things will be appreciated.
      I'm doing it on my own time.
    • By FadingCosmos
      Hey Guys,
      we bought a V989 Air 16GB golden Tablet on gearbest.com and the touchscreen is not working at all. The tablet boots and you see android icons (chinese) but you can't click, swipe or anything (zero reaction at all). the buttons on the right side are working. we made a factory reset, no change. then i tried flashing the device with a chinese onda software and that process seemed to work, but still no touch screen reaction. 
      do you have any suggestions what i could try?
      ould this be a problem which is not resolvable by software?
      or maybe not resolvable at all?

      we tried to get our money back but gearbest.com knows how to avoid this. 
      In the serial number i have something like xxxxxxxV5A000379

      thank you!
    • By Omar Chaudhry
      I purchased Onda V989 Air Core8 (32GB) , having serial Number : V989ABFAV3D00065 in December, 2015.
      Since last 2 months I am having problem of automatic Shut downs.
      Battery is full, and I be just using simple apps, like Facebook or Browser, and this tablet just gives a message of Shutting Down, and then shuts down. First it used to happen once or twice a day. But now it happens even after 10 or 15 minutes, so it has become almost impossible to use the tab.
      I have not changed / upgraded any ROM or any software into it, since I bought it.  It still has its original Android version 4.4.4, and Firmware version # V1.0.1_v3
      I have tried Factory Reset multiple times, but the issue still remains there.
      Any idea or suggestion for me ?
      Thanks in advance.