Jump to content
Onda Forum
Gearbest $111 OFF Over $111.11  promotion
$111 OFF Over $111.11
Sign in to follow this  

onda v819 4G recovery menu missing

Recommended Posts

Hi all,

I have one of this tablets and have some troubles with it.

Something happened and it cannot boot. In fact it boots and shows the lockscreen for a second and reboot itself.

I try to enter recovery menu but there isn't any.

only calibrating mode and fastboot mode.

How can I enter recovery menu in order to do a hard reset?

Thank you in advance!!!


I tried with brushtool but it did not connect as it should. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Lukypie
      Hi, I'm back again with another particular guide, this time just for android, which will show how to root every V80 Plus rom, this time for real. You probably know that the other guides are not working anymore due to newer roms adding a new layer of protection against modifications. SuperSU zips can't detect this on Android 5.1 since this is something that is used in Nougat or Marshmellow 

      Also, I will also explain how to use newer roms updates (Like the Android V7 version) and make it work on V3 (My tablet) since there are minor hardware changes like the Wi-Fi chip and the touchscreen vendor, I will show how to port the V3 drivers on the V7 ROM which is more stable, and smoother.

      Unix environment (Linux, MacOS, Cygwin/MinGW on Windows) I recommend Manjaro Linux, the AUR has all the programs we need here. ADB and Fastboot https://github.com/xpirt/img2sdat https://github.com/ggrandou/abootimg Unlocking bootloader Decent knowledge of ROM tweaking or at least in theory Basic Unix-like systems knowledge A BACKUP,  you will lost all data on your device By following this guide I take no responsibility on device bricks or data loss
      Common steps for both ROM tweaking and Rooting
      The first thing you have to do is to unlock the bootloader, reboot your tablet from Android and press the down button to access the fastboot mode, then connect via USB the tablet to a PC, you have to enter this command in order to unlock the bootloader (You can also use this tool) also if you want to install TWRP follow his guide. ' fastboot oem unlock '
      You will lose all data after oem bootloader unlocking
      Now you have to extract your ROM boot.img by downloading the correct ROM image (http://onda.cn/search.aspx?keyword=v80%20plus) and using abootimg in Linux/MacOS/Cygwin/MinGW, I won't explain how to compile it.

      What we have to do is basically extract the initrd and changing ro.secure=0 o ro.secure=1, which will allow for supersu to install without bootlooping and mounting system as rw, using modified system.img's and disable the protection which will put the device into a bootloop state
        Type the following command to extract the boot.img (You must be on the same folder where you downloaded the boot.img)
        ' abootimg -x boot.img '
      Now several files are created, we need to extract the initrd, put ' abootimg-unpack-initrd initrd.img '
      Go into the ramdisk folder and look for default.prop, open it with a text editor

      change ' ro.secure=1 ' to ' ro.secure=0 '  in the previous folder, type ' abootimg-pack-initrd initrd.modified.img '
      This will create initrd.modified.img which includes your modifications, now you have to create a new boot.img with the modifications you made, with this command ' abootimg --create boot.edited.img -r initrd.modified.img -k zImage -f bootimg.cfg -c "bootsize=xxxxxx" '

      Please note that in xxxx you have to put the new boot.img size, you can get the exact string by omitting the -c "bootsize=xxxxx" argument, which will give an error that will tell on the left the size you need to put, in my case it was 

      ' abootimg --create boot.edited.img -r initrd.modified.img -k zImage -f bootimg.cfg -c "bootsize=11868160" '
      for the V5 Kernel
      If you have done everything correctly, we got a working boot.edited.img, to flash that into your device you need to go back to the bootloader like when we oem unlocked the device. Put this command from a PC ' fastboot flash boot boot.edited.img ' 

      If everything went good, you just need to try to install supersu by flashing it with twrp or trying to mount as r/w the /system partition and see if it bootloops, if the rom does not even boot at all even if you just flashed the boot.img you did something wrong.
      ROM Tweaking and porting Vy android firmware version to Vx tablet

      Since I got really mad and frustrated by ONDA not releasing firmware also for older hardware revisions (Other may work for your older device, other may not) I decided to extract the drivers and firmware and put them to a newer rom, and it is worth the score. New firmwares are more smooth and stable.
      As you know, some newer VX firmware ROM may not be compatible with your VY hardware revision device, in my example I had the V3 and I managed to use the V5 drivers (The V5 version works good with the V3 tablet hardware rev) to use the V7 firmware. 
      This may probably work also with a V5 tablet.
      Don't know if this works with V1

      Extracting drivers and files needed
      Boot.img patching: In order to get drivers working, make sure you followed the steps for creating the modified boot.img kernel which works on your device, cause it is mandatory or you will get a bootloop.

      Q: Can older boot.img/kernels work with newer/older firmwares?
      A: Yes, they seems to be pretty similiar so in my example I used V5 boot.img in order to get drivers working for the V7 ROM which has a slightly different hardware
      Without extracting the following files and firmware you will just have the touchscreen working, but not the wifi or the bluetooth, they require firmwares located into system files! And Without the boot.img you can't do anything with the new rom!
      Once you downloaded every ROM you need, in my example I had the V3 Hardware revision, I will put V5 drivers which works too on V3 into the V7 ROM, this time we need to find and extract the system.img using simg2img by using this command, easier than saying it. ' simg2img system.img system.img.raw ' 
      Now mount it as read-write with, ' mount -o rw system.img.raw /mnt '

        Firmware extracting
      I needed to extract the following files in order to have everything, copy them on the desktop, if unsure you could copy everything like /etc /lib/ /vendor / because I can't know if you are trying another ROM revisions, because they may require different files, find yours by yourself!
      (This may be a lot of trial-and-error but the files should be the same, you could try that also with V1 to V5/v7,  tell me if it works! Idk about other hardware revisions!)
      --------------------------------- V5 ROM ----------------------------------------
        /mnt/vendor - Other blobs needed  /mnt/bin/wpa_supplicant - Needed for the wifi correctly working /mnt/etc/firmware - Proprietary blobs dirvers needed for Wifi, bluetooth and other things to work. /mnt/etc/sensor_hal_config_default.xml - Needed in order to the accelerometer to work. /mnt/build.prop - Needed if you have problems with some apps like Facebook. /mnt/lib/hw/bluetooth.so - In order to make bluetooth working

      ------------------------------------------------------------------------------------ System.img patching
      Once you got those files, do the same simg2img command with the system.img ROM you want to put the drivers on, in my case the V7. Mount it with read-write on /mnt or everywhere you like, then patch all the files by copy-pasting the one you extracted before and replacing them on the new ROM using a file manager with root permissions like thunar, nautilus or pcmanfm  
      tl;dr, what I did? 
      Extracted the two system.img's of two different roms Copy-pasted and replaced the files I told you before from the working V5 ROM (Even owning the V3 one but that has the same hardware of V5 I suppose) to the newer V7 rom I want to use is that hard?

      System.img repacking and flashing
      Make sure you unmounted the system.img.raw by ' umount /mnt ' put this command  ' img2simg system.img.raw system.edited.img ' 
      Now you just need to flash it like the boot.img before, so ' fastboot flash system system.edited.img ' ' fastboot reboot system ' 

      If everything went good , you will reboot into your fresh-new system! Stable if you compare the first sh*tty firmwares they made, there are less slowdowns and bugs like the strecthed windows in the multitasking area.

      Modified V5 boot.img: https://mega.nz/#!OlgygJjK!wTv2L9yfCGsqkV7ShGX4Cub-EGdvh3ROtuZxvMzVGoM
      Modified V7 system.img to make it work with V3 using V5 firmware: Soon...

      If you made your own working, please tell me, I will put the links, just specify the ROM and the source drivers you used! 
      Useful commands:
      From Fastboot: 
      fastboot format system - Formats the android systems Warning: it does not reset the phone, if you reboot you won't have any android system fastboot format data - Formats the /data folders (Program files like apps data) -  It does a factory reset, but the ROM will still be the same. fastboot format userdata - Formats the /sdcard folder fastboot reboot system - Reboots into Android fastboot reboot recovery - reboots into recovery From android:
      ' adb reboot recovery '  Reboots into TWRP ' adb reboot system ' Reboots normally  'adb reboot bootloader ' - Reboots into fastboot
    • By Tom3392
      Hi all!
      Has anyone had success rooting the Lollipop on an oBook 20 Plus? Unfortunately, the most promising approach (IntelAndroid-FBRL / TWRM) does not work (messages like "Flashing /sbin/partlink ... Failed to get partition: /sbin/partlink Not found"). That's really a pity. I wonder why independent vendors still sell devices where the user is locked out from the device he actually paid for.
      Many thanks for any hint.
      Kind regards,
    • By Xuxi
      Hello guys, this is a guide (showing how to root and install TWRP for Onda V80 Plus) I found out on a Russian forum. I managed to root my Onda device with Android only, however, I am NOT an expert user to point out any technical errors (if available). That's why, TAKE THIS AT YOUR OWN RISK. I'm not responsible for any brick or other serious problems . 
      Special thanks to aleha81@4pda.ru for a great guide . 
      2017-04-10: DO NOT TRY TO RESTORE STOCK ROM/CUSTOM ROM IN TWRP. For some certain reasons whenever I try to restore stock rom in TWRP, the tablet bricks. Yes, it bricks and sometimes boot loop. However, do not worry too much, in case of brick, you can re-flash the stock rom following this guide.
      1. On your PC: download this file | mirror and extract it somewhere (Desktop is recommended, try to avoid long paths).
      2. On your tablet: Settings >> Developer Options >> Enable OEM unlocking and USB debugging. If Developer mode isn't available, open About Tablet and tap Build number several times (maybe 5 or 7) until you see the notification.
      3. Connect the tablet to your PC, install two drivers in folder drivers.
      1. Run start.bat (without administrative privileges), enter 81 to check whether the tablet could receive commands from your PC or not (if you see serial numbers, do the next steps).
      2. Enter 1: The tablet will reboot in to fastboot to install some drivers. After unlocking the bootloader, it will reboot into Android. REMEMBER that this step will wipe out all your internal data.
      3. Enter 2: On the internal memory will be copied _V80PLUS folder and its contents.
      4. Enter 3: The tablet will reboot into temp TWRP recovery. Further actions are done in it.

      5. In TWRP recovery mode, move the slider very very slowly to unlock your tablet (take it easy when doing this ). Then, make a backup of existing partitions (just in case), find and install v80_boottwrp.zip, after reboot, install SuperSU_xxx.zip. Now you can reboot into your tablet.
      If everything goes well, your Onda device has been rooted. Now you can install any apps requiring root access. Good luck!!!
      P/S: I am neither an English native speaker nor an IT expert, so some of the technical terminology confused me so much. Forgive me if you find anything difficult to understand ^^.
      Some images from my Onda V80 Plus:

    • By benda95280
      UPDATED 30/20/2016
      Hi everybody,
      I've just bought a Onda V989 Air V3.
      I'm happy with the new tablet for my last child, but i think the last version of the rom some have still some problems.
      (Or i'm the lucky owner of a defective tablet)
      I'll be happy to help other people, to find informations about the tablet, like roms, root ...
      So i'll try to do my best, with your help, to keep this post updated often.
      [General informations]
      Onda firmware ( published description) is designated device model and  hardware assembly version ( v# ) specific. 
      V989 Air v3 is designated as  " Black Gold Edition " device hardware version  ( 16 GB / 32 GB  ) Aug 2015 original firmware release 
      [RemixOs or Stock Rom]
      I'm on RemixOs since few Weeks, and i've no more crazy bugs like : Freeze during installation via Playstore, Laggs, Stockage issue ...
      When you boot, on the stock ROM i wasn"t having information like "Optimisation des Applications 1/102 ..." So you know when it is just Loading ...
      You have a cool TaskBar
          1. RemixOS
      - This Rom doesn't include gapps.
      - To have all languages, you have to find the tick box to unlock it. (Tell me where, i'll be happy to add the information here)
          [How to root]
      Use first link under, and unzip it into folder Root (created by you) on SdCard (Internal or ExtSD)
      Install "Update.apk" and launch it.
      Do [Local Update], search your previously created folder, and select "ondaos_v989_Root.zip", click [Update].
          [Links - Downloads]
          1. Only Root with SuperSu
      Link : http://www.mediafire.com/download/48cdh7ansltmvl4/Onda_V989_Root.rar
      My opinion: Work like a charm / Best Way to do it / Update SuperSu via Playstore work well with "normal installation"
          1. Flashfireapk [RECOMMENDED]
      Flash Without recovery
      My opinion: Work well for flashing Mods / ZIP on our V989
          2. LSpeed Mod [TESTED ON FRESH ROM] PlayStore
      My opinion: Launcher little less laggy..
          3. Universal Init.D [TESTED] Playstore
      My opinion: Working (TESTED with Creation of file test via folder Init.D)
          4. GovTuner
      Link : http://forum.xda-developers.com/android/software-hacking/mod-gov-tuner-project-29th-june-2016-t3407828
      Installation: FlashFire
      My opinion: Crazy !

          4. GL-Tools
      You want more fluidity in your games ? It's possible !
      Link : https://play.google.com/store/apps/details?id=com.n0n3m4.gltools
      How-to : http://www.theandroidhow.com/2014/06/play-high-end-games-with-gltools.html
          5. Titanium Backup
      Uninstall all chinese software with it.
      My opinion: Best way to remove chinese software !
          6. Nova launcher
      My opinion: Light and fluid
      [Bugs i've encountered on STOCK ROM]
      - During installing apps via Playstore (not downloading) it freeze all the tablet, and unfreeze when apps installed.
      - Some big games on playstore, donwload (Game + Additional data), install, and fail without reason or just blackscreen for some second and return to launcher.
      - With "Universal Init.D", Tweaks ABS, when i boot up the tablet, it's a little laggy and cannot have SU working for 1-2 mn, and see on bottom:
       "Init. Universal have got root permission accorded"
       "Lucky Patcher have got root permission accorded"
      After that, everything it's ok and smooth.
      (Maybe due to Universal Init.d that launch script ?)
      [What can be working on ?]
      - Cannot get working Link2SD
      I've try with / without second partition / EXT4, doesn't seen the partition.
      - Not enought space on "System partition" maybe add/extend 512Mb more ?
      - Have a debloated rom with init.d support
      - Found / Have a custom Recovery ? FlashFire
      - Try to get working OndaZ Air Rom: 
      I've tried it, but got some problems like: OP showed in front of applications size / Shutdown of the tabled under 59% / Games are "Slow" / Sometime lines bug with color are show
      (Take look at my post 30/10/2016)
      [ Read This ]
      Any Thanks, likes, or other things will be appreciated.
      I'm doing it on my own time.
    • By Che68
      Hi to all,
      I recently purchased the tablet V919 Air CH DualOS (no 3G), and I found out I do not have root permissions. Can someone help me unlock my device?